oneshotlife-pythonのブログ

Pythonを好んで使っているプログラマです。Pythonこそが最強のプログラミング言語だと思っています。Pythonは使いやすいです。Pythonは書きやすいです。Pythonは読みやすいです。Pythonはパワフルです。Pythonは一貫性があります。Pythonが好きです。

ImportError: No module named win32api

Scrapy shellを起動しようとしたら以下のエラーが出た。

ImportError: No module named win32api

試しに、win32apiをインストールしてみた。

PS>pip install win32api
pip : You are using pip version 7.1.0, however version 9.0.0 is available.
発生場所 行:1 文字:1
+ pip install win32api
+ ~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (You are using p...0 is available.:String) [], RemoteE 
   xception
    + FullyQualifiedErrorId : NativeCommandError
 
You should consider upgrading via the 'python -m pip install --upgrade pip' command.
Collecting win32api
  Could not find a version that satisfies the requirement win32api (from versions: )
No matching distribution found for win32api

そんなの無いって!!!

stackoverflowで解決方法を見つけた。pypiwin32というモジュール名らしい。

PS>pip install pypiwin32
pip : You are using pip version 7.1.0, however version 9.0.0 is available.
発生場所 行:1 文字:1
+ pip install pypiwin32
+ ~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (You are using p...0 is available.:String) [], RemoteE 
   xception
    + FullyQualifiedErrorId : NativeCommandError
 
You should consider upgrading via the 'python -m pip install --upgrade pip' command.
Collecting pypiwin32
  Downloading pypiwin32-219-cp27-none-win32.whl (6.7MB)
Installing collected packages: pypiwin32
Successfully installed pypiwin32-219